YourStore Status Page - Buzzle Outage – Incident details
All systems operational
Buzzle Outage
Resolved
Major outage
Started 9 months ago28. October 2025Lasted about 4 hours28. October 202509:5714:15UTC
Affected
Buzzle Platform
Major outage from 9:57 AM to 1:57 PM, Operational from 1:57 PM to 2:15 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
The platform has been completely restored. We are continuing to monitor the situation.
Identified
UTC
Identified
UTC
We identified a malfunction of the Buzzle platform and have informed our responsible service provider. We hope for a prompt resolution and will inform you here again when an update is available.