YourStore Status Page - Buzzle Outage – Incident details
All systems operational
Buzzle Outage
Resolved
Major outage
Started 4 months ago22. March 2026Lasted about 5 hours22. March 202608:2813:50UTC
Affected
Buzzle Platform
Major outage from 8:28 AM to 1:50 PM
Updates
Resolved
UTC
Resolved
UTC
The platform has been completely restored. We are continuing to monitor the situation.
Identified
UTC
Identified
UTC
We identified a malfunction of the Buzzle platform and have informed our responsible service provider. We hope for a prompt resolution and will inform you here again when an update is available.